blog}

Le funzioni INDICE e CONFRONTA di Excel (Index/Match)

Per illustrare l’utilità delle funzione INDICE e CONFRONTA utilizzate in coppia, consideriamo la loro applicazione in un foglio Excel utilizzato per l’iscrizione di studenti a dei giochi sportivi studenteschi

Per ricercare il numero di pettorale degli atleti iscritti ai 1000 m è possibile utilizzare la seguente funzione composta:

=INDICE(colonna da cui restituire un valore; (CONFRONTA(valore di ricerca; colonna in cui ricercare il valore; 0))

che applicata al nostro esempio per lo studente SABBADINI diventa:

=INDICE($A$3:$B$148;CONFRONTA(H3;$B$3:$B$148;0);0)

Di fatto il confrotnto andrebbe esteso non solo al cognome ma al cognome unitamente al nome, classe e sesso. Per cui la formula completa diventa:

=INDICE($A$3:$B$148;CONFRONTA(H3&I3&J3&K3;($B$3:$B$148)&($C$3:$C$148)&($D$3:$D$148)&($E$3:$E$148);0);1)

che è possibile copiare in tutte le celle della colonna G

ti è piaciuto l'articolo? condividi

sharing my ICT knowledge and expertise through the documentation of my experiences

Eros Sormani

Mi occupo di progettazione e sviluppo di soluzioni software e di creazione, implementazione e mantenimento di infrastrutture digitali

Altri Articoli del BLOG

Torna su